Quick Help

The knowledgebase is a categorized collection of answers to frequently asked questions (FAQ) and articles. You can read articles in this category or select a subcategory that you are interested in.



 Services may not be automatically started when upgrading from F-Secure Internet Gatekeeper 5.xx to 5.40

Solution

Symptoms

When you upgrade F-Secure Internet Gatekeeper from version 5.xx to version 5.40, services may not be automatically started.

Diagnosis

The following operating systems are affected: CentOS/RHEL 7, Debian 8, Ubuntu 16.04 and SLES 12.

Internet Gatekeeper 5.40 introduces native support for systemd. In the previous releases, the services were managed by SysV-style init scripts.

Systemd attempts to provide backward compatibility with the SysV init scripts. While systemd is aware of the product services, it may not be able to report the correct status when the services are started or stopped after a restart. This may cause that the enabled services are not automatically started when the product is upgraded.

Solution

There are two optional ways to solve the issue:

  • Restart the machine. This allows systemd to load the configuration and manage the services automatically according to the product configuration set in the Internet Gatekeeper Web UI.
  • Start the services manually and refresh systemd service statuses. Login to the system and enter the following command as a root user:
    • # systemctl daemon-reload
    • # /opt/f-secure/fsigk/libexec/fsigk-reload.sh 
      Note: This command must be run outside the product installer directory (fsigk-5.40.73)!

Note: CentOS/RHEL 7.2 users and other platforms using systemd version 219-19.el7 or similar: Due to a change (seehttps://bugzilla.redhat.com/show_bug.cgi?id=1285492) how systemd handles SysV-style init scripts, the product services were not starting automatically at restart. If you have added a workaround, for example by replacing the init script symlinks in /etc/init.d/ by regular files, or by starting the services via /etc/rc.local, it should be removed after upgrading to product version 5.40.

 
Was this article helpful? yes / no

 
Powered by Help Desk Software HESK, brought to you by SysAid